Very slow release memory when closing the program

Found a bug in "Everything"? report it here
Post Reply
Debugger
Posts: 531
Joined: Thu Jan 26, 2017 11:56 am

Very slow release memory when closing the program

Post by Debugger » Sun Jan 28, 2018 5:18 pm

Very slow release memory when closing the program. The application still works in the background for some time!

Version 1.4.1.877 (x64)
Using memory about 2-3 GB

therube
Posts: 2362
Joined: Thu Sep 03, 2009 6:48 pm

Re: Very slow release memory when closing the program

Post by therube » Sun Jan 28, 2018 5:27 pm

How many files are you indexing?

What settings do you have enabled under Everything Options | Indexes?

Debugger
Posts: 531
Joined: Thu Jan 26, 2017 11:56 am

Re: Very slow release memory when closing the program

Post by Debugger » Sun Jan 28, 2018 5:31 pm


void
Site Admin
Posts: 4965
Joined: Fri Oct 16, 2009 11:31 pm

Re: Very slow release memory when closing the program

Post by void » Mon Jan 29, 2018 11:36 pm

Could you please send a debug log after closing "Everything"?

I suspect the slowness is from Everything saving your database to disk, not releasing memory.

To create and send a debug log:
  • In Everything, type in the following search and press ENTER:
  • /debug_log
  • Exit Everything
  • Wait for the Everything process to close.
  • Send your %TEMP%\Everything Debug Log.txt to support@voidtools.com

Debugger
Posts: 531
Joined: Thu Jan 26, 2017 11:56 am

Re: Very slow release memory when closing the program

Post by Debugger » Wed Jan 31, 2018 8:28 am

You're right - in the - Everything tool, everything is based on a database file on the hard disk compared to another tool, where all data is stored ONLY on a fast physical memory RAM, so all operations end immediately.

void
Site Admin
Posts: 4965
Joined: Fri Oct 16, 2009 11:31 pm

Re: Very slow release memory when closing the program

Post by void » Wed Jan 31, 2018 10:21 am

There is the -no-db command line option to only store the database in memory:
Everything.exe -no-db

Note: Please make sure Everything is not running before using the -no-db command line option.
Note: Everything will reindex all your drives everytime you run it.

Post Reply