Bug with new tabs and filters

Discussion related to "Everything" 1.5 Alpha.
Post Reply
vsub
Posts: 439
Joined: Sat Nov 12, 2011 11:51 am

Bug with new tabs and filters

Post by vsub »

Using the latest version
Creating a new tab ignores the current filter
For example if I switch to "Picture" and open a new tab,the filter will still stay in "Picture" but display all files as if "Everything" is selected
NotNull
Posts: 5252
Joined: Wed May 24, 2017 9:22 pm

Re: Bug with new tabs and filters

Post by NotNull »

Each tab operates independently of the other. In older 1.5 versions this was different indeed.

New tabs will use the filter from the Home setting (Options > General > Home)
If that is not configured (i.e. "Use lats value"), the new tab should use the same filter as the last one.
vsub
Posts: 439
Joined: Sat Nov 12, 2011 11:51 am

Re: Bug with new tabs and filters

Post by vsub »

The new filter for Home is set to "Everything" and opening a new tab does display everything as if the "Everything" filter is selected but the combobox containing the filters still stays on the last used filter even if the actual result in the result list is displaying everything as if the everything filter is selected

I am not saying I want the new tab to display the last used filter,I am saying that the combobox does not change to the filter I select for Home but it actually filters the result properly
NotNull
Posts: 5252
Joined: Wed May 24, 2017 9:22 pm

Re: Bug with new tabs and filters

Post by NotNull »

Ah, that is what you meant!

I get that same behaviour. Seems like you found a bug (Tabs are still Work In Progress; still needs a lot of finetuning)
void
Developer
Posts: 15283
Joined: Fri Oct 16, 2009 11:31 pm

Re: Bug with new tabs and filters

Post by void »

This will be fixed in the next alpha update.

Thank you for the bug report.
void
Developer
Posts: 15283
Joined: Fri Oct 16, 2009 11:31 pm

Re: Bug with new tabs and filters

Post by void »

Everything 1.5.0.1367a fixes an issue with setting up the home search for a new tab.

The correct filter should now be activated.
The correct sort should now be shown.
Post Reply