~ in filename: works for local files, but not for remote files

Found a bug in "Everything"? report it here
Post Reply
Alex_Void
Posts: 1
Joined: Tue Jan 10, 2017 1:14 pm

~ in filename: works for local files, but not for remote files

Post by Alex_Void » Tue Apr 02, 2019 3:31 pm

There are files with a "~" (tilde) in the filename. Eg. the infamous Microsoft Office locking files
~$Team-Meeting.pptx

They contain user information about the user who has opened the corresponding file
Team-Meeting.pptx
. Some are old and distributed among many folders. I want to delete them.
So, what's wrong? If I find them via Everything
c: ~
or
c: "~"
(doesn't matter) on my local disk c:, I can open the file or the folder normally. And the context menu (right mouse click) looks like the one on Windows Explorer.
But when I do the very same search on a network drive
w: ~
or
w: "~"
I cannot open the file nor the folder. And the context menu looks poorly:
2019-04-02_171805.jpg
w: is being included in Everything via
Options, Indexes, Folders
and apart from that behaves normally.
Environment:
Everything v1.4.1.935 (x64)
Microsoft Windows [Version 10.0.17134.648]
You do not have the required permissions to view the files attached to this post.

void
Site Admin
Posts: 4770
Joined: Fri Oct 16, 2009 11:31 pm

Re: ~ in filename: works for local files, but not for remote files

Post by void » Wed Apr 03, 2019 6:21 am

This usually occurs when you right click a file that no longer exists.

Please try updating your remote files from Tools -> Options -> Folders -> Remote folder -> Update Now.

If the issue persists, please check your debug output for the failure reason:
  • In Everything, type in the following search and press ENTER:
    /debug
What is shown in the debug console when you right click a ~ file?

To close the debug console:
  • In Everything, type in the following search and press ENTER:
    /debug

Post Reply