Offline volumes cause unresponsiveness

Found a bug in "Everything"? report it here
Post Reply
pglpm
Posts: 2
Joined: Wed Mar 06, 2019 10:09 am

Offline volumes cause unresponsiveness

Post by pglpm » Wed Mar 06, 2019 10:27 am

This bug concerns Version 1.4.1.935 (x86), and didn't seem to be present in versions 1.3.x.

From time to time Everything is unresponsive: I call its window from the system tray, but the window takes about 60+ to seconds to appear.

To investigate the problem I run Everything in debug mode. The cause seems to be this: I have two drive letters (Y:, Z:) that refer to external network locations ("\\location\etc"). They are only accessible for a limited part of the day. The delay happens whenever Everything inquires Windows about those drives:

Code: Select all

QueryDosDevice Y: \Device\LanmanRedirector\;Y:[...]
Y:\ GetVolumeNameForVolumeMountPoint FAILED 87
QueryDosDevice Z: \Device\LanmanRedirector\;Z:[...]
Z:\ GetVolumeNameForVolumeMountPoint FAILED 87
ntfs volume create list 0.040916 seconds
To try to solve this, I UNchecked "Automatically include new fixed volumes" and "Automatically include new removable volumes", and checked "Automatically remove offline volumes" from the Indexes/NTFS and Indexes/ReFS options. Note also that I UNchecked the option "search and index existing volumes" (or similar) at install time.

Unfortunately this didn't solve the problem.

I then also added Y: and Z: to the excluded list. But the delay still appears.

Is it possible to solve this situation somehow, and tell Everything to inquire Windows ONLY about the volumes listed in the Index/NTFS options?


Everything is an amazing program! I use it constantly during the day. Cheers!

void
Site Admin
Posts: 4846
Joined: Fri Oct 16, 2009 11:31 pm

Re: Offline volumes cause unresponsiveness

Post by void » Thu Mar 07, 2019 5:21 am

Thanks for bringing this to my attention.

Please try Everything 1.4.1.937.

Everything 1.4.1.937 will no longer try to access NTFS or ReFS volumes on offline mapped network drives.

pglpm
Posts: 2
Joined: Wed Mar 06, 2019 10:09 am

Re: Offline volumes cause unresponsiveness

Post by pglpm » Sat Mar 16, 2019 6:59 pm

Thank you! Will report on Monday on how it's working.

Post Reply