Page 1 of 1

searching bug

Posted: Mon Feb 18, 2019 9:59 pm
by chriszxlu
i'm not be good at english, i hope u can understand me.
under the default setting!
IF the file name is "ABC-123a.mp4" or DIR name is "ABC-123b", you search "ABC-123" CAN NOT GET THE "ABC-123a.mp4" "ABC-123b" even you DISABLE the option "Match whole filename when using wildcards"
you must search " ABC-123* " , you can get the anwser file "ABC-123a.mp4" OR dir "ABC-123b".
but if you search " ABC-" (even no *) , you can get the anwser file "ABC-123a.mp4 ABC-456.mp3 .....and so on.
is the a BUG? or something wrong with my setting

Re: searching bug

Posted: Tue Feb 19, 2019 1:30 am
by void
Do you have match whole words enabled under the main Search menu? -If so, please disable it.

Re: searching bug

Posted: Fri Feb 22, 2019 10:30 pm
by chriszxlu
i said : even you DISABLE the option "Match whole filename when using wildcards"

so Im disable it!

Re: searching bug

Posted: Fri Feb 22, 2019 11:00 pm
by NotNull
chriszxlu wrote:
Fri Feb 22, 2019 10:30 pm
i said : even you DISABLE the option "Match whole filename when using wildcards"
is NOT the same as
void wrote:
Tue Feb 19, 2019 1:30 am
Do you have match whole words enabled under the main Search menu? -If so, please disable it.
As @void already mentioned, this Match Whole Word setting can be found in the menu under Search.

Re: searching bug

Posted: Fri Feb 22, 2019 11:00 pm
by vanisk
chriszxlu wrote:
Fri Feb 22, 2019 10:30 pm
i said : even you DISABLE the option "Match whole filename when using wildcards"

so Im disable it!
Both are different options.
"Match whole filename when using wildcards" is in Tools->Options->Search.

@void mentioned - "Match whole word" which is in Search Menu (Shortcut key Control+B)


[@Null, not again... both replied at the same time]

Re: searching bug

Posted: Fri Feb 22, 2019 11:13 pm
by NotNull
vanisk wrote:
Fri Feb 22, 2019 11:00 pm
[@Null, not again... both replied at the same time]
:lol: This time I beat you to it. See you the next round! :)

Re: searching bug

Posted: Sat Feb 23, 2019 12:11 am
by void
Please make sure no search options are checked under the Search menu:
Image

Re: searching bug

Posted: Sun Feb 24, 2019 12:36 pm
by chriszxlu
ok, i get it!!! thanks a lot~ everyone!!
thanks. 多谢,多谢!!!!