Everything not indexing C: on Windows 10

Found a bug in "Everything"? report it here
Post Reply
Arredondo
Posts: 4
Joined: Wed Jan 17, 2018 11:50 pm

Everything not indexing C: on Windows 10

Post by Arredondo » Thu Jan 18, 2018 12:04 am

I have version 1.4.1.877, and Everything is not indexing my NTFS system partition (C:). It indexes other partitions okay. I am a long time user and I know my way around the settings. It's not an administrative privileges issue either.

I beliveve it may be a bug because I installed version 1.3.4.686 and it worked okay (C: was indexed).

This has never happened to me before. The only new thing is that I am using Windows 10 via BootCamp on a MacBook Pro. Thus the C: partition, although NTFS, is physically located in the storage unit after three non-NTFS (mac) partitions.

May this be what's causing the problem?

void
Site Admin
Posts: 4851
Joined: Fri Oct 16, 2009 11:31 pm

Re: Everything not indexing C: on Windows 10

Post by void » Sun Jan 21, 2018 1:06 am

May this be what's causing the problem?
Possible, could you please send some information about your C: volume?
  • From a Command Prompt (Start -> Run -> cmd)
  • Type in the following commands:
    fsutil fsinfo volumeinfo c:
    fsutil fsinfo ntfsinfo c:
  • What is displayed in the command prompt?
Could you please send some Everything debug information?
  • In Everything, type in the following search and press ENTER:
    /debug
  • Type in the following search and press ENTER:
    /reindex
  • After reindexing is complete, please send a copy of the debug output to support@voidtools.com
  • To copy the debug output, please see Debug Help.
To hide the "Everything" debug console:
  • In Everything, type in the following search and press ENTER:
    /debug

Arredondo
Posts: 4
Joined: Wed Jan 17, 2018 11:50 pm

Re: Everything not indexing C: on Windows 10

Post by Arredondo » Sun Jan 21, 2018 9:23 am

Sure thing. Here goes:

fsutil fsinfo volumeinfo c:
[cut by void]
Volume Name : System
Max Component Length : 255
File System Name : NTFS
Is ReadWrite
Supports Case-sensitive filenames
Preserves Case of filenames
Supports Unicode in filenames
Preserves & Enforces ACL's
Supports file-based Compression
Supports Disk Quotas
Supports Sparse files
Supports Reparse Points
Returns Handle Close Result Information
Supports POSIX-style Unlink and Rename
Supports Object Identifiers
Supports Encrypted File System
Supports Named Streams
Supports Transactions
Supports Hard Links
Supports Extended Attributes
Supports Open By FileID
Supports USN Journal

This next command I had to run as admin, othersiwe it just returned 'Error: Access is denied.'

fsutil fsinfo ntfsinfo c:
[cut by void]
NTFS Version : 3.1
LFS Version : 2.0
Number Sectors : 0x0000000002b76dff
Total Clusters : 0x0000000002b76dff
Free Clusters : 0x000000000167bb41
Total Reserved : 0x0000000000000eca
Bytes Per Sector : 4096
Bytes Per Physical Sector : 4096
Bytes Per Cluster : 4096
Bytes Per FileRecord Segment : 1024
Clusters Per FileRecord Segment : 0
Mft Valid Data Length : 0x000000001c900000
Mft Start Lcn : 0x00000000000c0000
Mft2 Start Lcn : 0x0000000000000002
Mft Zone Start : 0x000000000161e460
Mft Zone End : 0x00000000016273a0
Max Device Trim Extent Count : 256
Max Device Trim Byte Count : 0xffffffff
Max Volume Trim Extent Count : 62
Max Volume Trim Byte Count : 0x40000000

For this next part I reinstalled Everything 1.4.1.877 x64. I's running as admin, Everything Service also running. As before, it did not index c:, but it did index other NTFS volumes (external HDD).

Below is the console output.
Cheers.

===start===

[cut by void]
read error c0000000
[cut by void]

===end===

void
Site Admin
Posts: 4851
Joined: Fri Oct 16, 2009 11:31 pm

Re: Everything not indexing C: on Windows 10

Post by void » Sun Jan 21, 2018 9:39 am

read error c0000000
Thanks for the debug information.

Please try the latest nightly build.

There is an issue with Everything 1.4.1.877 that would cause a read error with memory misalignment. It was fixed in 885.

To install the latest nightly build:
  • Completely exit Everything (right click the Everything system tray icon and click Exit)
  • Extract Everything.exe from the latest nightly zip, overwriting your existing Everything.exe
  • Restart Everything.

Arredondo
Posts: 4
Joined: Wed Jan 17, 2018 11:50 pm

Re: Everything not indexing C: on Windows 10

Post by Arredondo » Sun Jan 21, 2018 5:10 pm

Thanks for the reply. I tried version 894 but the problem persists. Same exact symptoms.

Here's the debug dump.
Cheers.

===start===
[cut by void]
===end===

void
Site Admin
Posts: 4851
Joined: Fri Oct 16, 2009 11:31 pm

Re: Everything not indexing C: on Windows 10

Post by void » Sun Jan 21, 2018 11:31 pm

Thanks for the debug log.
ntfs index: 74561 folders, 405809 files
removed 10 orphaned files in 0.021804 seconds
removed 4 orphaned folders in 0.005514 seconds
The debug log shows the C: drive was indexed successfully.

Does "Everything" show any results if you search for:
c:

Arredondo
Posts: 4
Joined: Wed Jan 17, 2018 11:50 pm

Re: Everything not indexing C: on Windows 10

Post by Arredondo » Sun Jan 21, 2018 11:48 pm

Hey! It's working! This is very odd. It wasn't searching c: when I took that last debug info. Maybe it just needed a system reboot? I don't know. Anyway, it's all good now.

Thanks void, I really appreciate the input.
Keep up the good work!

Post Reply