v1.3.3.658 (x64) db not always auto-updated

Found a bug in "Everything"? report it here
Post Reply
uds0
Posts: 1
Joined: Fri Nov 29, 2013 1:49 am

v1.3.3.658 (x64) db not always auto-updated

Post by uds0 » Fri Nov 29, 2013 2:00 am

This utility is a life saver. Having confidence in the search results is critical.

I installed a fingerprint driver (Digitalpersona) via installing the Run Time Engine. I knew what files should be there once the reader was plugged in and driver installation was complete, but the files in c:\windows\system32\driverstore\filerepository\dpersona... folder were missing from everything's results even after exit and reload. I saw them in windows explorer, so I rebuilt everything's db and they finally showed up. I was having trouble with files remaining in the results list after I deleted them (via everything or via explorer) in the current release (32-bit?), which is why I tried the 64-bit beta version.

Please take a peak and advise.

Hope this helps.

Thanks!

dhry
Posts: 11
Joined: Tue Apr 30, 2013 7:34 pm
Location: Phoenix, AZ, USA
Contact:

Re: v1.3.3.658 (x64) db not always auto-updated

Post by dhry » Wed Jan 22, 2014 10:57 pm

This has been happening with me as well with the newest version. I even went back to 1.2.1.452, but that version's result set is incomplete as well. I'm running the x64 build 1.3.3.658 and the results are just not being updated all the time. Using the service as well. I periodically look for files that I KNOW are there and they are not displayed in Everything (on NTFS partitions, definitely) and yet when I force a manual rebuild of the database all of a sudden they appear fine.

In addition, I tried running it against a network drive (using the indexes|folders option) that I know contains a LOT of files.. Everything started building the remote file list and then basically hung. Hangs every time and I literally have to endtask it and start it again.

For the moment I'm still using Locate32. It's not instant like Everything, but I have it updating once every couple of hours on schedule and at least 1) it shows all results, as expected, and 2) it does not freeze when updating contents of a remote network drive with thousands of files, and eventually completes as expected.

Regarding the Everything service, I notice that even if I STOP that service, I'm still able to enable it in Everything's options, and no error is thrown such as "Service not running!" I don't know if the service is working or not, nor what that port # is. Is that what the service is listening on that Everything connects to, or what Everything's listening on that the SERVICE connects to? If the latter, how does one configure the service to connect to a specified port when the service doesn't have any sort of configurable parameters that I can see..?
(Edit: found out how to uninstall and reinstall Service with specified port - thanks for documenting it)

Please let me know if there's anything I can do to get more information for troubleshooting these issues.

Dhry

Post Reply