Folder launch not maximised

Found a bug in "Everything"? report it here
Post Reply
meteorquake
Posts: 97
Joined: Thu Dec 15, 2016 9:44 pm

Folder launch not maximised

Post by meteorquake » Sun Feb 20, 2022 7:44 am

When I open a folder from Everything in Explorer it is not maximised. The same folder launched from windows Run command is maximised.
I suspect this is a bug - generally I like things maximised (although some programs have an opening splash screen). Launching a jpg in IrfanView it doesn't seem to have the issue.
David

NotNull
Posts: 3720
Joined: Wed May 24, 2017 9:22 pm

Re: Folder launch not maximised

Post by NotNull » Sun Feb 20, 2022 10:01 am

Not a bug.

Try this:
  • Close all opened Explorer windows (check with 'ALT+TAB' to see if there are any open)
  • Open a folder from Everything in Explorer, as you did before
  • Resize/Move the remaining Explorer window. DON'T use Maximize.
    I like to use 'ALT+SPACE' to resize/move a window as using the mouse is difficult near the borders of the screen.
  • When size is OK, press 'SHIFT' and click the X in the top-right corner of the window.
    That will save the window size for a next time.
  • Done.

P.S. Please specify your Windws- and Everything version next time.

void
Developer
Posts: 9595
Joined: Fri Oct 16, 2009 11:31 pm

Re: Folder launch not maximised

Post by void » Sun Feb 20, 2022 10:09 am

I think this might be a bug.

Everything is currently opening folders with SW_SHOW instead of SW_SHOWDEFAULT.


I will experiment with SW_SHOWDEFAULT as the default in the next alpha update.
This appears to give the desired behavior, that is, if the last Explorer window was maximized when closed, opening a folder from Everything will be maximized.

void
Developer
Posts: 9595
Joined: Fri Oct 16, 2009 11:31 pm

Re: Folder launch not maximised

Post by void » Tue Feb 22, 2022 5:36 am

Everything 1.5.0.1301a adds a shell_execute_show ini setting.

Everything will default to SW_SHOWDEFAULT (10)
The old behavior was SW_SHOW (5)

To change the show method when opening results:
  • In Everything 1.5, type in the following search and press ENTER:
    /shell_execute_show=x
  • where x can be one of the following:
    • 0 = Hide
    • 1 = Show Normal
    • 2 = Show Minimized
    • 3 = Show Maximized
    • 4 = Show Normal (No activate)
    • 5 = Show
    • 6 = Minimized
    • 7 = Show Minimized (No activate)
    • 8 = Show (No activate)
    • 9 = Restore
    • 10 = Show Default (default)
    • 11 = Force minimize
  • If successful, shell_execute_show=x is shown in the status bar for a few seconds.

Default: /shell_execute_show=10

TRILLOGY
Posts: 6
Joined: Wed Dec 02, 2020 5:04 pm

Re: Folder launch not maximised

Post by TRILLOGY » Mon Apr 11, 2022 10:12 pm

Version 1.4.1.1015 (x64)
All of my folders are opening maximized by default recently. I have a 34" ultra-wide and this is giving me whiplash as I go to normalize the size of every maximized folder window that opens.

I ran the Version 1.5a Portable version and the folder windows open normal size from there. Got excited and installed v1.5a, and now the windows are right back opening maximized. :(

I tried changing the default Explorer window size using Shift - X like one user above recommended. No luck there. Win + E opens a new Explorer window regular size so I don't think that is the problem. I executed the following to the .ini file but no luck:

/shell_execute_show=1
/shell_execute_show=5
/shell_execute_show=10

NotNull
Posts: 3720
Joined: Wed May 24, 2017 9:22 pm

Re: Folder launch not maximised

Post by NotNull » Mon Apr 11, 2022 11:23 pm

How do you start Everything?

If through a shortcut:
- right-click the shortcut
- Go to the Shortcut tab
- Make sure Run = Normal window.



2022-04-12 01_21_53-Window.png
2022-04-12 01_21_53-Window.png (14.46 KiB) Viewed 1957 times

void
Developer
Posts: 9595
Joined: Fri Oct 16, 2009 11:31 pm

Re: Folder launch not maximised

Post by void » Tue Apr 12, 2022 7:26 am

Please ensure Everything is running as a standard user:
  • In Everything, from the Tools menu, click Options.
  • Click the General tab on the left.
  • Check Store settings and data in %APPDATA%\Everything.
  • Uncheck Run as administrator.
  • Check Everything Service. (Please make sure this is tick-checked and not square-checked)
  • Click OK.
  • Exit Everything (right click the Everything tray icon and click Exit).
  • Restart Everything.

TRILLOGY
Posts: 6
Joined: Wed Dec 02, 2020 5:04 pm

Re: Folder launch not maximised

Post by TRILLOGY » Fri Apr 22, 2022 7:20 am

Thank you both for the responses. I already had the Run Window set to Normal and the Settings as specified above. I open Everything.exe from either a shortcut pinned to my Windows 10 taskbar or the icon in the tray. It's happening now with both versions of the program (v1.4 & v1.5a) now that I have them both running concurrently.

I should mention that I use Directory Opus as my file explorer replacement for Windows Explorer. However Win + E opens a new Directory Opus Lister to my predefined window size (not-maximized).

I installed the JumpToFolder app that NotNull has posted to these forums and that is a nice feature since it opens Everything results in the desired-size window. I planted a JumpToFolder shortcut in my custom toolbar in Dopus so I can just Win + E / JumpToFolder / launch search from now on until I can figure out what is causing the max window size from Everything every time.

void
Developer
Posts: 9595
Joined: Fri Oct 16, 2009 11:31 pm

Re: Folder launch not maximised

Post by void » Tue Apr 26, 2022 1:07 am

If you exit Everything (File -> Exit) and relaunch Everything, does Everything start maximized?
-If so, programs run from Everything might be inheriting this maximize setting.



Is Everything running as an administrator?
-Is Run as an administrator tick-checked or square-checked under Everything -> Tools -> Options -> General?
-Please make sure this is unchecked.



Please try changing your open folders command:
  • In Everything, from the Tools menu, click Options.
  • Click the Context Menu tab on the left.
  • Select Open (Folders).
  • Change the Command to:
    $exec("C:\Program Files\GPSoftware\Directory Opus\dopusRT.exe" /acmd Go "%1")
  • Click OK.

void
Developer
Posts: 9595
Joined: Fri Oct 16, 2009 11:31 pm

Re: Folder launch not maximised

Post by void » Sat Apr 30, 2022 3:34 am

If you are using Everything 1.5, please try the latest build 1311a+.

1311a will now open programs with SW_NORMAL instead of SW_SHOWDEFAULT.
This will open programs with the default show method.

TRILLOGY
Posts: 6
Joined: Wed Dec 02, 2020 5:04 pm

Re: Folder launch not maximised

Post by TRILLOGY » Thu May 05, 2022 12:33 pm

If you exit Everything (File -> Exit) and relaunch Everything, does Everything start maximized?
No Everything starts exactly how I exited out.

Everything running as an administrator is unchecked.

I changed Tools > Options > Context Menu > Open (Folders) > Command to what you wrote:

$exec("C:\Program Files\GPSoftware\Directory Opus\dopusRT.exe" /acmd Go "%1")

However this results in folders not opening at all so I restored defaults for that command.

I updated to the latest v1.5.0.1312a-x64 and still having the folders open maximized. I can just deal with it for now and continue trying JumpToFolder. I appreciate the help!

Post Reply