"lasthour" search

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
burgundy
Posts: 264
Joined: Fri Oct 16, 2009 9:50 am

"lasthour" search

Post by burgundy »

Am having problems finding any files created in the last hour using "dc:lasthour". It also happens with variations in syntax such as:

dc:lasthour
dc:last1hour
dc:lasthours
dc:last1hours


The problem also happens when using minutes, such as in "dc:last10minutes".

The problem corrects itself when I fiddle about with "Force rebuild" for the index AND/OR deleting the Everything .db index file. It's hard to tell which action corrects it because exiting and re-launching Everything seems to be a factor too.

Could this be related to the setting in NTFS Options for for "Load USN Journal into the Recent Changes database"?

(Am using Win XP/SP3.)
void
Developer
Posts: 15267
Joined: Fri Oct 16, 2009 11:31 pm

Re: "lasthour" search

Post by void »

For Everything 1.4, please try the following search:

dc:past1hours

Please make sure "Index Date Created" is enabled from Tools -> Options -> Indexes.



For Everything 1.5, please try the following search:

dc:1hour


Could this be related to the setting in NTFS Options for for "Load USN Journal into the Recent Changes database"?
No, please leave this option disabled.
burgundy
Posts: 264
Joined: Fri Oct 16, 2009 9:50 am

Re: "lasthour" search

Post by burgundy »

Hello, "Index Date Created" has been enabled throughout my tests on both Everything 1.4 and Everything 1.5.
"Load USN Journal into the Recent Changes database" was disabled in 1.4 but enabled in 1.5.

On Everything 1.5 using "dc:1hour" as suggested DOES work. On the other hand I found earlier that "dc:last1hour" does NOT work.

However, on Everything 1.4 using "dc:past1hours" as suggested does NOT work.

What interpretation can be made of this? The information under the menu entry for "Search Syntax" in both 1.4 and 1.5 indicated that all these commands I have mentioned in my posts should work but it seems only some do. Please advise as these searches are something I really would like to get right. Thank you.
void
Developer
Posts: 15267
Joined: Fri Oct 16, 2009 11:31 pm

Re: "lasthour" search

Post by void »

However, on Everything 1.4 using "dc:past1hours" as suggested does NOT work.
What happens for you?
What is the date created range you are seeing in your results?



In Everything 1.4, last, past and prev are all the same.
That is they all refer to the previous calendar month.

For example lastmonth == 2022-05-01 .. 2022-05-31

When used with a digit, the range is from <x> months ago from now.

For example: last2months == 2022-04-14 .. 2022-06-14



I'll look into making sure Everything 1.5 does the same.
burgundy
Posts: 264
Joined: Fri Oct 16, 2009 9:50 am

Re: "lasthour" search

Post by burgundy »

Excuse my delay in responding. I find once again that using "last" is not interchangeable with "past"

"past" works as expected.
"last"does not work as expected. It does not find as many files as "past"

I am using Everything Version 1.5.0.1315a (x86)
void
Developer
Posts: 15267
Joined: Fri Oct 16, 2009 11:31 pm

Re: "lasthour" search

Post by void »

"past" and "last" will behave the same in the next alpha update.
"last" is currently using the last calendar month/year (1315a and earlier).

For now, please use "past" or specify the exact date range, eg: 2022-06-18..2022-07-18
void
Developer
Posts: 15267
Joined: Fri Oct 16, 2009 11:31 pm

Re: "lasthour" search

Post by void »

Everything 1.5.0.1316a will now treat past and last as the same.
Post Reply