Search using * and ? wildcards

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
konste
Posts: 3
Joined: Mon Jun 14, 2021 6:13 pm

Search using * and ? wildcards

Post by konste » Mon Jun 14, 2021 6:20 pm

I wonder if there is a way to switch Everything to use simple "*" and "?" wildcards for searches, rather than learn Everything specific search syntax or go for a full blown RegEx syntax, which would be major overkill for me.

99% of my searches are like "file name starts with blah" and I am looking to do those searching with the minimal typing besides the string "blah" which typically comes from clipboard.

Any advice?

Thank you!
Konstantin

horst.epp
Posts: 482
Joined: Fri Apr 04, 2014 3:24 pm

Re: Search using * and ? wildcards

Post by horst.epp » Mon Jun 14, 2021 6:32 pm

* and ? wildcards work fine in Everything.
Check that what you have set under Search

konste
Posts: 3
Joined: Mon Jun 14, 2021 6:13 pm

Re: Search using * and ? wildcards

Post by konste » Mon Jun 14, 2021 6:42 pm

When I type "blah" in the search field Everything finds all the files with the substring "blah" anywhere in the file name and that is not what I need. I need something like "blah*". Is it supposed to work? What do I need to configure for that?

NotNull
Posts: 3129
Joined: Wed May 24, 2017 9:22 pm

Re: Search using * and ? wildcards

Post by NotNull » Mon Jun 14, 2021 7:41 pm

When you have Match whole filename when using wildcards enabled (Menu:Tools > Options > Search):

- searching for
bla*
will find file-and foldernames that start with bla
- searching for
*bla
will find file-and foldernames that end with bla
- searching for
bla
will find files and folders that have bla somewhere in their name

konste
Posts: 3
Joined: Mon Jun 14, 2021 6:13 pm

Re: Search using * and ? wildcards

Post by konste » Mon Jun 14, 2021 8:05 pm

Oh, wow, I got it! Thank you very much!

sassoon12
Posts: 2
Joined: Wed Jun 16, 2021 3:29 pm

Re: Search using * and ? wildcards

Post by sassoon12 » Wed Jun 16, 2021 9:13 pm

I enabled Match whole filename when using wildcards but typing *xml gave no search results and I have plenty of XML files on my system.

NotNull
Posts: 3129
Joined: Wed May 24, 2017 9:22 pm

Re: Search using * and ? wildcards

Post by NotNull » Wed Jun 16, 2021 9:32 pm

Maybe you enabled the Enable Regex option or one of the other options under Menu:Search?
Can you try it with only the 'Everything' option enabled in theSearch menu?


Quick tip: If one of those options is enabled, it will be shown in the status bar. Double-clicking them will reset them.

Post Reply