indexing on computer startup is slowing computer

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
kumar
Posts: 5
Joined: Fri Sep 27, 2019 1:16 am

indexing on computer startup is slowing computer

Post by kumar » Sat Nov 09, 2019 3:11 am

Everytime my computer starts and I logon to it, Everything consumes high disk use, I'm guessing because it is rebuilding index. How can I defer this activity to say 10 minutes after logon?

void
Site Admin
Posts: 4931
Joined: Fri Oct 16, 2009 11:31 pm

Re: indexing on computer startup is slowing computer

Post by void » Sat Nov 09, 2019 7:15 am

Please try launching Everything with the -load-delay command line option:
  • First step is to disable Everything from starting on system startup normally:
  • In Everything, from the Tools menu, click Options.
  • Click the General tab on the left.
  • Uncheck Start Everything on system startup..
  • Click OK.
  • Now we need to create a new method for starting Everything on system startup:
  • In Windows Explorer, navigate to:
    shell:startup
  • Right click in this folder and under the New submenu, click Shortcut.
  • Type in:
    C:\Program Files\Everything\Everything.exe
    where C:\Program Files\Everything is the location of your Everything.exe
  • Click Next.
  • Type in a name for this shortcut, eg: Everything
  • Click Finish.
  • Right click this new shortcut and click Properties.
  • Change the Target from:
    "C:\Program Files\Everything\Everything.exe"
    to:
    "C:\Program Files\Everything\Everything.exe" -startup -load-delay 600000
    where 600000 is the number of milliseconds to wait before loading or creating the Everything database.
  • Click OK.
Everything should only index once, please make sure Everything is able to save its database to disk:
  • In Everything, from the Tools menu, click Options.
  • Click the General tab on the left.
  • Check Store settings and data in %APPDATA%\Everything.
  • Click OK.

NotNull
Posts: 1527
Joined: Wed May 24, 2017 9:22 pm

Re: indexing on computer startup is slowing computer

Post by NotNull » Sat Nov 09, 2019 7:34 pm

void wrote:
Sat Nov 09, 2019 7:15 am
"C:\Program Files\Everything\Everything.exe" -load-delay 600000
And if you want Everything to start in the background, add -startup to that command:

Code: Select all

"C:\Program Files\Everything\Everything.exe"  -startup   -load-delay 600000

Post Reply