The search does not work or takes too long without progress.

General discussion related to "Everything".
Post Reply
Debugger
Posts: 530
Joined: Thu Jan 26, 2017 11:56 am

The search does not work or takes too long without progress.

Post by Debugger » Wed Dec 19, 2018 9:59 am

The search does not work or takes too long without progress.

"Updating the database" only shows it all the time.
I will add that I have installed a new version Everytjing and I have this problem.

void
Site Admin
Posts: 4806
Joined: Fri Oct 16, 2009 11:31 pm

Re: The search does not work or takes too long without progress.

Post by void » Thu Dec 20, 2018 7:01 am

Please try deleting your Everything.db:
  • Kill the Everything process:
    • Press Ctrl + Shift + ESC
    • Click the Details (or Processes) tab
    • Select Everything and click End Process.
  • In Windows Explorer, navigate to:
    %LOCALAPPDATA%\Everything
  • Delete your Everything.db
  • Restart Everything.

Debugger
Posts: 530
Joined: Thu Jan 26, 2017 11:56 am

Re: The search does not work or takes too long without progress.

Post by Debugger » Thu Dec 27, 2018 2:30 pm

void wrote:
Thu Dec 20, 2018 7:01 am
Please try deleting your Everything.db:
  • Kill the Everything process:
    • Press Ctrl + Shift + ESC
    • Click the Details (or Processes) tab
    • Select Everything and click End Process.
  • In Windows Explorer, navigate to:
    %LOCALAPPDATA%\Everything
  • Delete your Everything.db
  • Restart Everything.
Everything:
30-40 minutes Updating + send question - It's too long :o ,
how to speed it up?

MasterSeeker is much faster

Oliverh
Posts: 14
Joined: Wed Jan 03, 2018 3:03 pm

Re: The search does not work or takes too long without progress.

Post by Oliverh » Thu Dec 27, 2018 4:41 pm

Do you have multiple hard drives or partitions?

Maybe one of them is the culprit, could it be a failing or weakened hard drive?

You can try your luck by excluding them manually one by one in the program options (tools > options > index > ntfs > list of the local ntfs volumes, click one > uncheck the boxes).

Just an idea :)

Debugger
Posts: 530
Joined: Thu Jan 26, 2017 11:56 am

Re: The search does not work or takes too long without progress.

Post by Debugger » Thu Dec 27, 2018 5:59 pm

Oliverh - The problem is not in the disks, because they work perfectly with MasterSeeker, the super-speed of displaying millions of files has always been at the highest level. But the Everything performance problem has always been the same. You can eliminate this if you set up without an update, but then new files will not be displayed in Everhting, only all the time old files. So the problem is only in Everything. Every time after starting I have to wait half an hour, it's a big exaggeration.
Perhaps large file changes, such as deletion, prolong the updating of the file list on disks.

void
Site Admin
Posts: 4806
Joined: Fri Oct 16, 2009 11:31 pm

Re: The search does not work or takes too long without progress.

Post by void » Sat Dec 29, 2018 4:04 am

If Everything is taking too long to start:
  • Terminate your Everything.exe process with the Task Manager.
  • Open your %APPDATA%\Everything\Everything.ini and change the following line:
    monitor_pause=0
    to:
    monitor_pause=1
  • Save changes and restart Everything.
Alternately, if you have Everything running, please try disabling the Everything monitors:
  • In Everything, type in the following and press ENTER:
    /monitor_pause
To manually update your indexes:
  • In Everything, type in the following and press ENTER:
    /reindex
If you prefer Everything to update in real-time, re-enable your monitors:
  • In Everything, type in the following and press ENTER:
    /monitor_resume

Post Reply