Solved: Context menu entries don't work

Discussion related to "Everything" 1.5 Alpha.
Post Reply
Posts: 1402
Joined: Fri Apr 04, 2014 3:24 pm

Solved: Context menu entries don't work

Post by horst.epp »

I run the x64 portable version.
I have imported my Everyting settings and the context menu entries look ok.
I have set the Open Path entry to Total commander.
TC is started but not with the selected dir or file.
Explore parth is set to XYplorer, it starts XYplorer but without the required pathes.
Explore is set to Windows Explorer and this entry starts Explorer with its default.

So for me the context menu entries do not function at all :(

Here the entries from the ini file

Code: Select all

open_folder_command2=$exec("C:\Tools\Wincmd\totalcmd64.exe" /a /o /s "%1")
open_path_command2=$exec("C:\Tools\Wincmd\totalcmd64.exe" /a /o /s "%1")
explore_command2=$exec("%SystemRoot%\explorer.exe" /n,/e,/select,"%1")
explore_path_command2=$exec("C:\Tools\XYplorer\XYplorer.exe" "%1")
Last edited by horst.epp on Sun Mar 14, 2021 9:43 am, edited 1 time in total.
Posts: 5385
Joined: Wed May 24, 2017 9:22 pm

Re: Context menu entries don't work

Post by NotNull »

Command-line parameters are not passed along:
"C:\test\_FileMgr\TotalCommander_950b7x64\TOTALCMD64.EXE" (location on my system) will be started instead.

Also: As the /O option (re-use existing/running Total Commander) is not being passed along, a new TC instance will be started.

I have imported my Everyting settings
Be careful with system-wide shell integration settings, like:
- .efu file association (Menu:Tools > Options > General)
- URL protocol (Menu:Tools > Options > General)
- global window hotkeys (Menu:Tools > Options > General > Keyboard)

Those can be linked to one Everything instance only.

BTW: Thanks for the XYPlorer syntax; I need that later today for a write-up :)
Posts: 16073
Joined: Fri Oct 16, 2009 11:31 pm

Re: Context menu entries don't work

Post by void »

Thanks for the bug report.

Everything was not passing the parameters correctly.

Please try the latest Everything 1.5 Alpha.

Version fixes an issue with passing parameters to custom commands.
Post Reply