C# Sample - getting 0 results for all searches

Plug-in and third party software discussion.
Post Reply
fillip
Posts: 1
Joined: Thu Nov 28, 2013 11:25 pm

C# Sample - getting 0 results for all searches

Post by fillip » Thu Nov 28, 2013 11:52 pm

Did anyone else encounter this?

I have it set up to target x86 and the dll loads correctly. But all searches return 0 results. I read somewhere else that I need to run as Administrator. That still doesn't help.

Any guidance would be appreciated.

Thanks

icybridge
Posts: 1
Joined: Mon Dec 30, 2013 6:19 am

Re: C# Sample - getting 0 results for all searches

Post by icybridge » Mon Dec 30, 2013 6:30 am

I got the same result with VS2012 update4. I had it working with update 2 so it is related to VS I think.
Everything_SetSearch(textBox1.Text); returns 0
Everything_Query(); returns false

Can't see any exceptions but the Everything_GetNumResults() returns 0

Arsenal
Posts: 1
Joined: Wed Jan 15, 2014 3:17 pm

Re: C# Sample - getting 0 results for all searches

Post by Arsenal » Wed Jan 15, 2014 3:27 pm

I got (using VS2010EE) an exception, something about stack being misaligned. What I had to do to get it work was update the API according to the header to look like this:
[DllImport("Everything.dll")]
public static extern bool Everything_Query(bool isUnicode);

Note the added bool isUnicode. I also had to call it with true to make it find anything.

Also Everything needs to be running, so the dll is not providing a complete search engine it seems.

Post Reply