How do I use wholefilename: ?

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
Pod
Posts: 3
Joined: Fri Feb 02, 2018 10:32 am

How do I use wholefilename: ?

Post by Pod » Thu Mar 07, 2019 10:08 am

I have the latest version of everything.

If I type
hosts
into the search bar I get a lot of results (134), but I'm after a file exactly named "hosts" (e.g. C:\windows\system32\drivers\etc\hosts), so I want to filter this down a bit to save myself some mental effort.

So I try
wholefilename: hosts
. This results in a blank search result.
wfn: hosts
gives the same result.

If I type
wholeword: hosts
I get 134 results again.

However, if I type
hosts
and press CLTR+B to enable WHOLE WORD mode I get 24 objects, which behaves the way I'd expect
wholefilename:
to work.

1. How come ww: and CTRL+B differ, given that they both claim to be "whole word" ?
2. How come wholefilename isn't matching my "hosts" file for a search of "hosts"? Infact, "wholefilename: " always seems to return 0 no matter what I type.

Thanks,

void
Site Admin
Posts: 4876
Joined: Fri Oct 16, 2009 11:31 pm

Re: How do I use wholefilename: ?

Post by void » Thu Mar 07, 2019 10:31 am

Some notes:

Please make sure there is no space after a search modifier, for example, to search for hosts using wholewords, search for:
wholeword:hosts

wholefilename: followed by a space will try to match files with no filename, please try without the space, for example:
wholefilename:hosts

Also, if you have match path enabled from the Search menu, wholefilename will match the full path and filename. You could override this with:
nopath:wholefilename:hosts
1. How come ww: and CTRL+B differ, given that they both claim to be "whole word" ?
It looks like you are searching for:
wholeword:<space>hosts

which Everything interprets as:
wholeword: AND hosts

The wholeword: with a space after it will match every single file.
2. How come wholefilename isn't matching my "hosts" file for a search of "hosts"? Infact, "wholefilename: " always seems to return 0 no matter what I type.
Please try searching for (without any spaces):
wholefilename:hosts

And make sure Match Path is disabled from the search menu, or please try searching for:
nopath:wholefilename:hosts

Pod
Posts: 3
Joined: Fri Feb 02, 2018 10:32 am

Re: How do I use wholefilename: ?

Post by Pod » Wed Mar 13, 2019 11:23 am

Thanks for the reply :)

I can't believe the solution was so simple! I had misunderstood the search syntax, I had thought they were merely "flags" that could occur anywhere in the search bar and they would apply the entire search, but it seems like they're specific operations with specific operands that follow directly after the ':'.

This also might explain why some of my other uses of the search modifiers never resulted in "ideal" results :)

Post Reply