Not updating deleted folders in Windows 7

Found a bug in "Everything"? report it here
Post Reply
Phi
Posts: 3
Joined: Wed Mar 24, 2010 2:23 pm

Not updating deleted folders in Windows 7

Post by Phi » Wed Mar 24, 2010 2:42 pm

Hi,

Everything v 1.2.1.371

The program does not update deleted folders in Windows 7.
Looking in the Explorer it is erased at once. If I go to properties ->
Volumes -> 'Include in database', uncheck, Apply, check and Apply, then
all is ok, byt very tedious :D

Tried to previous post: Displaying non existing files
No success !

Tried to just restart Everthing, nu success !

Using:
Computer: Dell XPS M1530, Disk: Intel SSD, OS: Windows 7 Ultimate

All in all a Very nice program !

Kind regards, Per

therube
Posts: 2853
Joined: Thu Sep 03, 2009 6:48 pm

Re: Not updating deleted folders in Windows 7

Post by therube » Wed Mar 24, 2010 4:31 pm

Do you feel it has to do with the SSD?
As in you do not have the issue on a "regular" HDD?

Everything and SSDs

Phi
Posts: 3
Joined: Wed Mar 24, 2010 2:23 pm

Re: Not updating deleted folders in Windows 7

Post by Phi » Wed Mar 24, 2010 11:00 pm

SSD issue?

It works fine with files, they are updated at once when deleted,
why not folders? Turning on and off the database for the partition
in question does the job, so to me it looks like a bug, but I am
far from knowing the ins and outs of OS-file-reading.

What is happening when I turn the partition on and off? To me
it looks as if the program is re-reading the database, i.e. updating?

Ok, took a look the Errorlog.txt file, see below. In the last sections I have tried to delete a map called 'Test_Map' (don't see the name) and one map called 'Map2'.

1/19/2010 9:15:34 PM: Everything 1.2.1.371: .\src\db.cpp(18251): db::_update_drive(): DeviceIoControl(0x000000e4,FSCTL_READ_USN_JOURNAL,0x023efb54,40,0x023eff7c,65536,0x023efb50,0x00000000): GetLastError(): 21
2010-02-10 8:52:35 AM: Everything 1.2.1.371: d:\dev\everything\src\mu.h(1094): mu::ShellExecuteExUTF8_idlist(): ShellExecuteExW(): GetLastError(): 1223: failed to execute
2010-02-21 5:39:55 PM: Everything 1.2.1.371: .\src\db.cpp(18251): db::_update_drive(): DeviceIoControl(0x000000c8,FSCTL_READ_USN_JOURNAL,0x0217fb54,40,0x0217ff7c,65536,0x0217fb50,0x00000000): GetLastError(): 21
2010-03-16 9:27:47 PM: Everything 1.2.1.371: .\src\db.cpp(18251): db::_update_drive(): DeviceIoControl(0x000000e4,FSCTL_READ_USN_JOURNAL,0x01ebfb54,40,0x01ebff7c,65536,0x01ebfb50,0x00000000): GetLastError(): 21
2010-03-21 4:02:11 PM: Everything 1.2.1.371: .\src\db.cpp(18251): db::_update_drive(): DeviceIoControl(0x000004f0,FSCTL_READ_USN_JOURNAL,0x052bfb54,40,0x052bff7c,65536,0x052bfb50,0x00000000): GetLastError(): 21
2010-03-21 5:03:25 PM: Everything 1.2.1.371: d:\dev\everything\src\mu.h(1094): mu::ShellExecuteExUTF8_idlist(): ShellExecuteExW(): GetLastError(): 1223: failed to execute
2010-03-24 1:26:35 PM: Everything 1.2.1.371: .\src\tray.cpp(970): tray::update_hotkeys(): RegisterHotKey(): GetLastError(): 1409
2010-03-24 1:29:06 PM: Everything 1.2.1.371: .\src\tray.cpp(970): tray::update_hotkeys(): RegisterHotKey(): GetLastError(): 1409

2010-03-25 10:09:16 AM: Everything 1.2.1.371: d:\dev\everything\src\mu.h(1094): mu::ShellExecuteExUTF8_idlist(): ShellExecuteExW(): GetLastError(): 1155: failed to execute

2010-03-25 10:12:50 AM: Everything 1.2.1.371: d:\dev\everything\src\mu.h(1064): mu::ShellExecuteExUTF8(): ShellExecuteExW(): GetLastError(): 2: failed to execute E:\_Downloads\_Download\Map2

void
Site Admin
Posts: 6067
Joined: Fri Oct 16, 2009 11:31 pm

Re: Not updating deleted folders in Windows 7

Post by void » Fri Mar 26, 2010 4:58 am

It works fine with files, they are updated at once when deleted,
why not folders?
I am not sure why the folder deletion is being missed by "Everything".

Try making a new folder..
Does "Everything" find the newly created folder "New Folder"?
Try deleting the newly created folder, does "Everything" remove this folder?

Try making a new folder and renaming it to "test folder"
Does "Everything" find "test folder"?
Try deleting the "test folder", does "Everything" remove this folder?

Try checking the volume for errors with chkdsk.
What is happening when I turn the partition on and off?
Any change to the list of volumes to include in the database will force "Everything" to re-index all volumes.
Ok, took a look the Errorlog.txt file, see below. In the last sections I have tried to delete a map called 'Test_Map' (don't see the name) and one map called 'Map2'.
Were Test_Map and Map2 files or folders?

Phi
Posts: 3
Joined: Wed Mar 24, 2010 2:23 pm

Re: Not updating deleted folders in Windows 7

Post by Phi » Fri Mar 26, 2010 11:05 pm

Try making a new folder..
Does "Everything" find the newly created folder "New Folder"?
Try deleting the newly created folder, does "Everything" remove this folder?
Yes and No.
Try making a new folder and renaming it to "test folder"
Does "Everything" find "test folder"?
Try deleting the "test folder", does "Everything" remove this folder?
This is exactly what I did with 'Test_Map' and 'Map2', yes they were folders.
I have done it again. Creating a new folder, renaming it in Everything, renaming it in Explorer, renaming it in Everything, renaming it in Explorer etc and it works perfectly, but after that it fails to 'delete' (still see the folder in Everything) but it goes away at once in Explorer.
Try checking the volume for errors with chkdsk.
It's a new SSD. Well anyway it's in two partitions and I have tried it on both and no difference,
can't delete folders.
Any change to the list of volumes to include in the database will force "Everything" to re-index all volumes.
Thanks, that's how I thought it was.
Ok, took a look the Errorlog.txt file, see below. In the last sections I have tried to delete a map called 'Test_Map' (don't see the name) and one map called 'Map2'.
What I was trying to say here is that you get two different errors when doing the same thing, i.e trying to delete folders. Everything is reporting an error in the logfile so you are detecting a malfunction in your program?
Were Test_Map and Map2 files or folders?
As I said above, they were folders.

daspud
Posts: 102
Joined: Wed Apr 01, 2009 3:15 am

Re: Not updating deleted folders in Windows 7

Post by daspud » Sun Mar 28, 2010 3:29 pm

I am also getting various problems when deleting files and folders in Win 7 (64 bit).

I use SE to find files I want to get rid of and when I start deleting them from the list I often get "Program not responding" and folders and files still showing up after they have been deleted. But the folders still showing up has also been in W7 alone. I delete files/folders and they are gone, but still show in the list on the screen.

I will track down the error log next time and see if there are any clues there.

Post Reply