USN Journal - Max-Size seems to be handled as 32-bit only

Found a bug in "Everything"? report it here
Post Reply
Rallib
Posts: 3
Joined: Sun Apr 29, 2018 12:04 pm

USN Journal - Max-Size seems to be handled as 32-bit only

Post by Rallib » Sun Apr 29, 2018 12:21 pm

Could it be that in "Options\Indexes\NTFS:" the field "USN Journal Maximum size" actually handles values as 32-bit integers rather than the 64-bit as that they are represented by NTFS internally?

:arrow: While "fsutil usn queryjournal" outputs "Maximum Size: 0x0000000100000000" in Everything there is displayed "Maximum Size: 0" KB.

void
Site Admin
Posts: 4831
Joined: Fri Oct 16, 2009 11:31 pm

Re: USN Journal - Max-Size seems to be handled as 32-bit only

Post by void » Mon Apr 30, 2018 1:08 am

Thanks for bringing this to my attention.

Yes, the USN Journal Maximum Size and USN Journal Allocation Delta should both be 64bit values.

I've fixed this for the next version of Everything.

Typically the maximum size is usually small.
The default values for maximum size are:
On Windows Vista and later (Including Windows 10): 32MB
Windows XP: 8MB

The default values for allocation delta are:
On Windows Vista and later (Including Windows 10): 4MB
Windows XP: 1MB

Any reason why it is set to 4GB?

When setting the maximum size to 0 or the allocation delta to 0 the default values are used.
Note: The maximum size is not changed until the next allocation delta is reached.

What is your allocation delta set to?

Rallib
Posts: 3
Joined: Sun Apr 29, 2018 12:04 pm

Re: USN Journal - Max-Size seems to be handled as 32-bit only

Post by Rallib » Wed May 02, 2018 6:02 pm

void wrote: Any reason why it is set to 4GB?
I did not apply that setting manually/knowingly.

I just realised the value of "0 KB" when looking at the volume's USN Parameters in Everything and started to investigate that conspicuity.

The volume has a size of 9.1TB occupying a "10TB" Ironwolf drive.

void wrote:What is your allocation delta set to?
The allocation delta is set to "0x0000000040000000" (fsutil) / "1048576 KB" (Everything).

Post Reply