Clicking .url Files in Everything causes problems elsewhere

Found a bug in "Everything"? report it here
Post Reply
a.voider
Posts: 10
Joined: Thu Sep 04, 2014 9:00 pm

Clicking .url Files in Everything causes problems elsewhere

Post by a.voider » Wed Apr 04, 2018 3:20 am

Hi, thanks for creating this awesome program! I'm using Everything 1.4.1.895 with Windows 10 x64.

Just a bug I wanted to report:
When I double-click .url files in Everything, it sometimes then prevents Windows Explorer/File Explorer (Windows 10) or my outlook (and perhaps other programs) from being able to send a link to Firefox (my default browser). That is, after having double-clicked a url file in Everything, when I double-click url files in Explorer (or when I click a link in an outlook email), it will do nothing. Clicking url files on Everything still works, but trying to do so elsewhere no longer does. I can usually fix this by restarting my Firefox.

Everything doesn't cause this every time I click a url file from there, but only sometimes... And I can't figure out the determining factor(s). I seem to recall having had this problem for a long while now.

It's a really annoying bug for me since I like creating a crap of url files on my HDD (it works better for me than bookmarks for some things, so no useless comments about that please).

Thanks! Please fix this!

NotNull
Posts: 1364
Joined: Wed May 24, 2017 9:22 pm

Re: Clicking .url Files in Everything causes problems elsewhere

Post by NotNull » Wed Apr 04, 2018 9:06 am

Are you running Everything as Administrator?
Programs that are running under a "lower" account are not allowed to talk to programs running under a higher account
If you are running Everything with an administartor account, programs started from Everything are also running as Administrator.

If applicable, Change the following settings under Menu:Tools > Options > General
- Enable Everything Service
- Disable Run as administrator

a.voider
Posts: 10
Joined: Thu Sep 04, 2014 9:00 pm

Re: Clicking .url Files in Everything causes problems elsewhere

Post by a.voider » Thu Apr 05, 2018 3:15 am

NotNull wrote:Are you running Everything as Administrator?
Programs that are running under a "lower" account are not allowed to talk to programs running under a higher account
If you are running Everything with an administartor account, programs started from Everything are also running as Administrator.

If applicable, Change the following settings under Menu:Tools > Options > General
- Enable Everything Service
- Disable Run as administrator
Thanks, that does sound like the problem. Let me try it and see if the problem ever crops up again. Danke!

NotNull
Posts: 1364
Joined: Wed May 24, 2017 9:22 pm

Re: Clicking .url Files in Everything causes problems elsewhere

Post by NotNull » Fri Apr 06, 2018 7:59 pm

a.voider wrote: Thanks, that does sound like the problem. Let me try it and see if the problem ever crops up again. Danke!
In that case: I hope I never hear from you again :lol: :D (about this).
Or better: let the other people here know if it works or not. It may help them with their problem.

Post Reply