Strange bug involving SumatraPDF

Found a bug in "Everything"? report it here
Post Reply
raf
Posts: 1
Joined: Sat Mar 24, 2018 6:58 pm

Strange bug involving SumatraPDF

Post by raf » Sat Mar 24, 2018 7:03 pm

If I open a PDF in Sumatra from Everything and I try to open another into a new tab, from Windows Explorer, it does not work. Opening a second PDF from Everything is fine.

If I start Sumatra from Windows Explorer, then open a second PDF from Everything, and then a third from Windows Explorer, that works too. If I start Sumatra by itself then I can open PDFs from wherever without a problem.

So, it seems that opening a PDF from Everything stops Sumatra from opening further PDFs from Windows Explorer. I can't imagine why this could be.

This was not a problem with Everything before. With the last update to Everything, this behaviour appeared. I don't know if this is Everything's fault or Sumatra's, but I've also lodged a bug report with SumatraPDF's developer.

I'm using v1.4.1.877 (x64) on a standard Windows 10 installation.

therube
Posts: 2290
Joined: Thu Sep 03, 2009 6:48 pm

Re: Strange bug involving SumatraPDF

Post by therube » Sun Mar 25, 2018 12:32 pm

Are Everything / Sumatra running at different privilege levels (say Limited vs Admin, kind of thing)?

horst.epp
Posts: 180
Joined: Fri Apr 04, 2014 3:24 pm

Re: Strange bug involving SumatraPDF

Post by horst.epp » Sun Mar 25, 2018 3:54 pm

No such problem here with Everything x64 1.4.1.899 and SumatraPDF x64 3.2.10766.
Everything service running and Everything itself with normal rights.
I can open any combination of PDFs from Everything, Explorer and Total Commander.
All PDFs are opened in new tabs of the running SumatryPDF.

void
Site Admin
Posts: 4821
Joined: Fri Oct 16, 2009 11:31 pm

Re: Strange bug involving SumatraPDF

Post by void » Mon Mar 26, 2018 12:32 am

Please try running Everything as a standard user:
  • In Everything, from the Tools menu, click Options.
  • Click the General tab on the left.
  • Check Everything service.
  • Uncheck Run as administrator.
  • Click OK.
  • Restart Everything (right click the Everything tray icon and click Exit).

Post Reply