ReFS on Windows Server 2016

Found a bug in "Everything"? report it here
macote
Posts: 2
Joined: Sat Dec 17, 2016 9:08 pm

ReFS on Windows Server 2016

Postby macote » Thu Dec 29, 2016 6:06 pm

Everything fails to display files located on my ReFS volumes. This happens on Windows Server 2016. Here's some related log file entries:

2016-12-29 13:01:12.173: add found refs volume: \\?\Volume{x} | R: | | x
2016-12-29 13:01:12.173: add found refs volume: \\?\Volume{x} | S: | | x
...
2016-12-29 13:01:21.548: open volume \\?\Volume{x}
2016-12-29 13:01:21.548: opened 896 0.000145
2016-12-29 13:01:21.548: refs sector size 512
2016-12-29 13:01:21.644: serial number x
2016-12-29 13:01:21.649: system_table_page 0000000000000001
2016-12-29 13:01:21.649: system page count 0
2016-12-29 13:01:21.649: add root
2016-12-29 13:01:21.649: frn 00000000000000000000000000000600 to page offset not found
2016-12-29 13:01:21.649: 0 folders, 0 files
2016-12-29 13:01:21.649: 2 reads, 8192 bytes read, 1 out of order reads, 0 extra fragments, 2 seeks
2016-12-29 13:01:21.649: 0.003490 seconds
2016-12-29 13:01:21.649: open volume \\?\Volume{x}
2016-12-29 13:01:21.649: opened 896 0.000077
2016-12-29 13:01:21.649: refs sector size 512
2016-12-29 13:01:21.750: serial number x
2016-12-29 13:01:21.751: system_table_page 0000000000000001
2016-12-29 13:01:21.751: system page count 0
2016-12-29 13:01:21.751: add root
2016-12-29 13:01:21.751: frn 00000000000000000000000000000600 to page offset not found
2016-12-29 13:01:21.751: 0 folders, 0 files
2016-12-29 13:01:21.751: 2 reads, 8192 bytes read, 1 out of order reads, 0 extra fragments, 2 seeks
2016-12-29 13:01:21.752: 0.000352 seconds

I have Version 1.4.1.809b (x64) installed.

Let me know if I can provide more information.

Thanks.

void
Site Admin
Posts: 3124
Joined: Fri Oct 16, 2009 11:31 pm

Re: ReFS on Windows Server 2016

Postby void » Thu Dec 29, 2016 9:57 pm

Thanks for the bug report, I'm looking into the issue..

void
Site Admin
Posts: 3124
Joined: Fri Oct 16, 2009 11:31 pm

Re: ReFS on Windows Server 2016

Postby void » Fri Dec 30, 2016 8:05 am

I'm able to reproduce the issue.
Windows Server 2016 introduces ReFS 3. It is structurally different to v1.

Working on a fix...

void
Site Admin
Posts: 3124
Joined: Fri Oct 16, 2009 11:31 pm

Re: ReFS on Windows Server 2016

Postby void » Thu Jan 26, 2017 7:45 am

I've added support for ReFS 3.x in Everything 1.4.1.833b or later.

macote
Posts: 2
Joined: Sat Dec 17, 2016 9:08 pm

Re: ReFS on Windows Server 2016

Postby macote » Sat Jan 28, 2017 12:27 am

That was quick!

I tried it and it looks like it's working.

Thank you for the great support!


Return to “Bug report”