Everything : I type in search field c:\temp and it doesn't show anything

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
tony01
Posts: 2
Joined: Sun Jun 14, 2015 3:07 am

Everything : I type in search field c:\temp and it doesn't show anything

Post by tony01 » Sat Feb 27, 2021 5:16 pm

Hi:
I am using Everything portable 64bits latest version and when I type in the search field
c:\temp
doesn't show anything
Even I check "Enable Regex" and I got the same thing, it shows nothing.
What is wrong? Any help will be appreciated.
Thanks

horst.epp
Posts: 397
Joined: Fri Apr 04, 2014 3:24 pm

Re: Everything : I type in search field c:\temp and it doesn't show anything

Post by horst.epp » Sat Feb 27, 2021 5:38 pm

tony01 wrote:
Sat Feb 27, 2021 5:16 pm
Hi:
I am using Everything portable 64bits latest version and when I type in the search field
c:\temp
doesn't show anything
Even I check "Enable Regex" and I got the same thing, it shows nothing.
What is wrong? Any help will be appreciated.
Thanks
By default there is no folder c:\temp and RegEx would not be needed to get it.
You may have no NTFS volume and not configured Folder indexing.
Also a portable version will need time after starting to get the index.
Also you can have set a filter which prevents to show this dir,
set your Filter setting to Everything

tony01
Posts: 2
Joined: Sun Jun 14, 2015 3:07 am

Re: Everything : I type in search field c:\temp and it doesn't show anything

Post by tony01 » Sat Feb 27, 2021 7:49 pm

Thank you for your answer.
I found the problem, When I check "Enable Regex" from Search Menu Tab,
For example, if I search "c:\program files\" Everything shows nothing,
but When I UNCHECK "Enable Regex" from Search Menu Tab, It works in the normal way.
Here an example of an advanced search with regular expressions and make sure
to uncheck "Enable Regex" from Search Menu Tab:

folders:"c:\program files\" regex:"Auto.*key"

As a result, everything shows "Autohotkey" folder, which is correct.
Thanks

jjk
Posts: 25
Joined: Mon Jun 15, 2009 6:57 pm

Re: Everything : I type in search field c:\temp and it doesn't show anything

Post by jjk » Sat Feb 27, 2021 8:55 pm

\ is a special character for regex. So try c:\\temp if you check Enable Regex
In Regex all special chars like \ . $ and others have to be preceeded by \ to be recognised as such.

Post Reply