Querying...long delay on first GUI launch.

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
V@no
Posts: 33
Joined: Sat Sep 04, 2010 1:57 pm

Querying...long delay on first GUI launch.

Post by V@no » Mon Mar 25, 2019 1:52 am

This wasn't an issue 2-3 versions ago, I don't think...basically after computer restart taskmanager shows that Everything is using quiet a bit of CPU/Disk, which is normal. When it settles, opening Everything window for the first time and typing anything in search bar, shows "Querying..." at status bar for 15-20 seconds. During this time it reads something from system C: drive only, no other drives are involved. After that "Querying" no longer occur until next reboot.

Using Windows 10 x64, portable Everything 1.4.1.935 x64 on E: ssd drive with "Everything service" activated. At indexes tab all checkboxes are checked except for multi-user, compress database and index data accessed. everything.db is 700mb with 11M files indexed.

Any ideas why and there is a way prevent this?

Thanks.

void
Site Admin
Posts: 4851
Joined: Fri Oct 16, 2009 11:31 pm

Re: Querying...long delay on first GUI launch.

Post by void » Mon Mar 25, 2019 4:01 am

Everything could have been paged to disk.

What is your active filter? -Shown under the Search menu.
Have you modified your Everything filter? Search -> Organize Filters -> Everything -> Edit -> Search should be blank.

V@no
Posts: 33
Joined: Sat Sep 04, 2010 1:57 pm

Re: Querying...long delay on first GUI launch.

Post by V@no » Mon Mar 25, 2019 4:19 am

No, all options are blank there.

Attaching everything.ini just in case.
You do not have the required permissions to view the files attached to this post.

void
Site Admin
Posts: 4851
Joined: Fri Oct 16, 2009 11:31 pm

Re: Querying...long delay on first GUI launch.

Post by void » Mon Mar 25, 2019 4:37 am

Thanks for the Everything.ini

Your Everything.ini appears to load instantly for me with 1 million files.

Could you please try running Everything in debug mode and sending some debug output?:
  • In Everything, type in the following search and press ENTER:
    /debug=1
    The next time you restart your PC everything will start in debug mode.
    After Everything has finished showing Querying... and your results are visible, could you please send your debug output to support@voidtools.com

To disable debug mode:
  • In Everything, type in the following search and press ENTER:
    /debug=0
  • Restart Everything.

V@no
Posts: 33
Joined: Sat Sep 04, 2010 1:57 pm

Re: Debugging Help

Post by V@no » Mon Mar 25, 2019 9:13 pm

Guess what...I no longer can reproduce it. Or there is something else involved than just reboot. Perhaps it's because my 4 3.5 HDDs are powering down after not being used for some time and the delay is simply waiting for them to spin up?
Last edited by therube on Mon Mar 25, 2019 11:14 pm, edited 1 time in total.
Reason: i believe this post was intended for this top, so moved

void
Site Admin
Posts: 4851
Joined: Fri Oct 16, 2009 11:31 pm

Re: Querying...long delay on first GUI launch.

Post by void » Tue Mar 26, 2019 12:47 am

Thanks for the reply.

From a similar incident we found that the home filter setting "use last filter" was the cause when using a complicated filter.

Please try changing your home filter to Everything:
  • In Everything, from the Tools menu, click Options.
  • Click the Home tab.
  • Change filter to Everything.
  • Click OK.
The complicated filter was a very long list of ORed paths, eg: c:\path1|c:\path2|c:\path3|etc...

Querying does not normally access your volumes, so HDDs powering down should have no effect. (unless you are querying for content)

V@no
Posts: 33
Joined: Sat Sep 04, 2010 1:57 pm

Re: Querying...long delay on first GUI launch.

Post by V@no » Wed Mar 27, 2019 11:11 pm

My filter is set to "use last value", which is simple "test" word. So far it seems I'm able reproduce it after I've been using computer for sometime after it woke up from sleep.

Attached a screenshot of resource monitor during the "Query.." time (captured the moment it finished querying after about 15 sec), it seems Everything is reading from pagefile..

P.S.
Now that I have better understanding how to reproduce it, I'll try capture the debug logs.
You do not have the required permissions to view the files attached to this post.

V@no
Posts: 33
Joined: Sat Sep 04, 2010 1:57 pm

Re: Querying...long delay on first GUI launch.

Post by V@no » Thu Mar 28, 2019 9:53 pm

I'm unable reproduce it with debug=1, perhaps because console window shown, windows doesn't swap Everything from memory as when it runs in the background?

NotNull
Posts: 1408
Joined: Wed May 24, 2017 9:22 pm

Re: Querying...long delay on first GUI launch.

Post by NotNull » Fri Mar 29, 2019 8:53 pm

There was another thread here - which I can't find right now - with a similar issue.
Moving Everything to the system disk (C:) solved the side effects of disks going to sleep (somehow Everything still needed disk access (IIRC)

Bit vague, but if you're having issues again: something worth considering

tuska
Posts: 183
Joined: Thu Jul 13, 2017 9:14 am

Re: Querying...long delay on first GUI launch.

Post by tuska » Fri Mar 29, 2019 10:26 pm

NotNull wrote:
Fri Mar 29, 2019 8:53 pm
There was another thread here - which I can't find right now - with a similar issue.
Moving Everything to the system disk (C:) solved the side effects of disks going to sleep (somehow Everything still needed disk access (IIRC)

Bit vague, but if you're having issues again: something worth considering
viewtopic.php?p=25101#p25101
Movement of the portable installation from D:\... to C:\Tools\Everything has caused me,
that there are no more unexpected crashes from this point on - since then there have been no crashes at all.

Alternative solution in my case was: Disabling Hibernation
Admin-DOS:

Code: Select all

powercfg -h off <enter> ... disable hibernation
powercfg /h on  <enter>

void
Site Admin
Posts: 4851
Joined: Fri Oct 16, 2009 11:31 pm

Re: Querying...long delay on first GUI launch.

Post by void » Sat Mar 30, 2019 2:57 am

To help prevent Everything from paging to disk, please try the following:

Enable hide on close:
  • In Everything, type in the following search and press ENTER:
    /hide_on_close=1
This will prevent the Everything window from actually closing, and just hide it instead.
When you open a new Everything search window, this hidden window is re-shown.

Remove the -startup command line option from your Everything startup command:
  • In Everything, from the Tools menu, click Options.
  • Click the General tab on the left.
  • Uncheck Start Everything on system startup.
  • Click OK.
  • In Windows Explorer, type the following into the address bar:
    shell:startup
  • Create a shortcut to your Everything.exe in this folder.
This will launch Everything on startup with an active window, which may help prevent Everything from being paged to disk.

Alternatively, try reducing the size of your Everything index, either by disabling some of the indexing options from Tools -> Options -> Indexes or by exclude unneeded files or folders from Tools -> Options -> Exclude and see if it helps.

NotNull
Posts: 1408
Joined: Wed May 24, 2017 9:22 pm

Re: Querying...long delay on first GUI launch.

Post by NotNull » Sat Mar 30, 2019 2:47 pm

tuska wrote:
Fri Mar 29, 2019 10:26 pm
viewtopic.php?p=25101#p25101
Movement of the portable installation from D:\... to C:\Tools\Everything has caused me,
that there are no more unexpected crashes from this point on - since then there have been no crashes at all.
Yes, that's the thread I couldn't find. Thank you, tuska!

Post Reply