How to make Everything works in limited user?

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
zakwithu
Posts: 1
Joined: Wed May 11, 2011 10:51 am

How to make Everything works in limited user?

Post by zakwithu » Wed May 11, 2011 11:03 am

hi voidtools - the owner of Everything search engine

thank you very much for this amazing tool. i started depending totally on it since long time. it really replaced any searching engine i ever know even google desktop. thanks again for this invention.

Question:
i have admin previleges and Everything-search working fine with no issue.
For other limited users using the same machine it is not working fine i got msg: unable to open volume \\.\C:
i explored your FAQ and this forum and i knew it requires some administrator rights.
i need to know what exact permission required to allow normal users to use this tool. i know it is USN Journal logging, but where to give this permission.


i hope to got my words.
thanks in advance

16succin
Posts: 1
Joined: Fri May 27, 2011 12:27 pm
Contact:

Re: How to make Everything works in limited user?

Post by 16succin » Mon May 30, 2011 9:18 am

Yea, I'm having the same problem, anyone can help? Plz. :)

redsand
Posts: 1
Joined: Wed Jul 13, 2011 9:57 pm

Re: How to make Everything works in limited user?

Post by redsand » Wed Jul 13, 2011 10:13 pm

Hi Voidtools developper,

I am having similar problems with Everything.

As Admin: all perfect.

For my normal permissions users... no results can be displayed in the Everything window (stays blank).
- I am on a Windows Server 2008 R2 configured as a Remote Desktop Server. Version is .452a
- I created a scheduled task for any log on .. with highest permissions... Task starts. No results can be displayed in Everything window.
- When I go to options, volumes... it never stores the selections for drives. When I click apply, a brief error message appears at bottom left of Everything.. but too fast to read. Clearly something around permissions to USN journal.
- in Debug mode I get:
==========================================================
enter mu options dialog...
WM_ACTIVATE 00000000 002602de
CreateFileW(): GetLastError(): 5: Failed to open volume \\?\Volume{c0f9e23a-6a9e-11e0-a428-806e6f6e6963}
CreateFileW(): GetLastError(): 5: Failed to open volume \\?\Volume{3ab2fca0-72a5-11e0-b40f-00155d081401}
CreateFileW(): GetLastError(): 5: Failed to open volume \\?\Volume{c0f9e23a-6a9e-11e0-a428-806e6f6e6963}
CreateFileW(): GetLastError(): 5: Failed to open volume \\?\Volume{3ab2fca0-72a5-11e0-b40f-00155d081401}
E: not found
db::create
db::destroy
clear results
disabling the focused item!
CreateFileW(): GetLastError(): 5: Failed to open volume \\?\Volume{3ab2fca0-72a5-11e0-b40f-00155d081401}
query
db::create
db::destroy
db::destroy
query
folder FRN qsort: 0.000000 seconds
convert frn to pointers: 0.000100 seconds
convert all file parent frns to pointers to folders and calculate file decode size: 0.000627 seconds
remove excluded folders: original folder count 0
remove excluded folders: folder count after removing orphan folders 0
remove excluded folders: 0.000814 seconds
remove excluded files: original file count 0
remove orphan files: file count after removing orphan files 0
remove orphan files: 0.002162 seconds
calculate largest folder size: 0 bytes: 0.000000 seconds
folder name qsort: 0.000000 seconds
calculate largest file size: 0 bytes: 0.000000 seconds
qsort file names indexes: 0.000000 seconds
create db time taken: 0.008332 seconds
loaded run history in 0.000000 seconds
start all monitors
query
restore selection (proir count 0 folders, 0 files, 0 special)
clear results
00618c38: 90, matchnext: 00000000, nomatchnext: 00000000
first t 6392568
found 0 folders, size 0, db search time taken: 0.000452 seconds
found 0 files, size 0, db search time taken: 0.000000 seconds
=========================================================

- I tried running as service.. all starts OK, DB gets created with SYSTEM in name... ETP logs, status bar tells me there are 180,000 items.. but Everything crashes with following info as soon as I click in the principal window.
- problem exists regarless as admin or not. It could be a different problem altogether as above..
- Stopped all firewall
=========================================================
Problem signature:
Problem Event Name: APPCRASH
Application Name: Everything-1.2.1.452a.exe
Application Version: 1.2.1.452
Application Timestamp: 4b123141
Fault Module Name: Everything-1.2.1.452a.exe
Fault Module Version: 1.2.1.452
Fault Module Timestamp: 4b123141
Exception Code: c0000005
Exception Offset: 00003758
OS Version: 6.1.7601.2.1.0.16.7
Locale ID: 4105
Additional Information 1: f47c
Additional Information 2: f47c323156f21450422dc02b78f41b02
Additional Information 3: c1d1
Additional Information 4: c1d13fde7b6044c1c044ac7700ab59f7
===============================================

Pls propose solutions to explore.

Regards,
Simple and high potential tool...

Darryl_Gittins
Posts: 24
Joined: Sat Jun 06, 2009 3:16 pm

Re: How to make Everything works in limited user?

Post by Darryl_Gittins » Sat Nov 19, 2011 11:02 pm

I have the same problem. I've tried removing and reinstalling and I've tried giving non-admins Full rights to the everything folder and the files withing.

Nothinbg helps. On all systems, non-admins cannot run Everything Search.


It's pretty poor practice to have to run as an admin on the system just to run this app. Surely there must be a fix?

Post Reply